Blank Page Screen After Login In ECP / OWA of Exchange 2016, 2013, 2010 Environment

Ashwani Tiwari ~ Modified: July 20th, 2022 ~ Exchange Server ~ 5 Minutes Reading

If you are trying to log in using browsers to access the Exchange Control Panel (ECP) or Outlook Web Access (OWA) show blank white website page, then you should go through this article once. Because, here we will discuss the most common reasons and techniques to resolve in the Exchange 2016, 2013, 2010 of ECP / OWA blank page after login and Exchange issue.

However, this issue is very common and usually occurs in the Exchange Server 2016 and below environment. When Exchange Administrator, use’s to access Admin Control panel and Outlook Application via EAC and OWA by providing the Username and Password and gets a white blank web page. Generally, this blank page screen problem arises due to SSL certificate binding and can be resolved by changing the binding settings in the IIS. Let’s discuss a scenario where a user gets a vacant web page and needs to fix this problem.

“I am working as an Exchange Administrator in an IT industry for over 5 years. Last night, I applied the Microsoft updates in the maintenance window and rebooted the Exchange server. After rebooting, I tried to open the Exchange Control Panel but it failed with a server unavailable error. In this situation, I found blank white screens after Login to ECP (Exchange Admin Panel). I started to panic a little because this problem can be the worst nightmare for IT guys. If you know any resolution method, then please let me know. Your suggestion would be really appreciated!!”

Why does Exchange ECP and OWA Display Blank Page after Login In Chrome?

There are many cases where Exchange administrator or user’s face the blank page issue even after Login the server and Outlook Web Access (OWA) panel. Some of the issues related to error are discussed here:

  • Exchange SSL Binding Configuration Problem:

If the SSL (Secure Socket Layer) Certificate is not bound properly with Exchange environment Exchange Control pane or management shell or do not have the correct information, then OWA and ECP may shows the blank web page. For better functionality of OWA, SSL binding should have the correct information and to assign the certificate to Exchange services, please visit:

  • Missing SSL Certificate for the Exchange Site: This issue arises when a user tries to access the Exchange Environment but the certificate needed for the specified server, is removed and lead to while blank page screen issue while accessing the account via ECP / OWA using Chrome, FireFox, Edge or any other browsers.

How to Find Event ID 15021 Blank Page Issue In Exchange 2013 / 2010

As Exchange Server generates a log file which contains the details of every event. While using SSL configuration for the endpoint, OWA/ EAC shows the blank web page. This error and its source can be found through the Exchange log file details.

 

If you view HttpEvent Error ID 15021 with a message of “an error occurred while using SSL configuration for endpoint 15021” then fix it using the following steps:

  • Open CMD (Command Prompt)

  • Now Run Command “netsh http show sslcert”
  • Now Save the Certificate Hash and Application ID Details of 127.0.0.1:443

In this example, save the value of fields in Notepad such as:

Certificate Hash: 01146cdc43de02f1d98fe4b9816a7ced2f7923e9
Application ID: 4dc3e181-e14b-fa21-b022-59fc669b0914

  • Now Run Command “netsh http delete sslcert ipport=0.0.0.0:444″ to delete the certificate and after that use command:

netsh http add sslcert ipport=0.0.0.0:444 certhash=01146cdc43de02f1d98fe4b9816a7ced2f7923e9 appid=”{ 4dc3e181-e14b-fa21-b022-59fc669b0914}”

To change replace the Application Id and Certificate Hash Value. At last, need to restart the Exchange Server. This Powershell Command Technique can help you to fix this White Blank Page issue after login can be fixed and allow the user to access Admin and User panel

Resolve Exchange ECP/ OWA Blank Page Issue via IIS Manager

In order to resolve the error event ID 15021 Webmail blank page after login, change the Binding Settings of SSL Certificate.

  • In the Client Access Server and Open the Internet Information Services (IIS) Manager.
  • After that, you need to expand your Sites. Then, click on the Default Web Site >> go to the Action pane and click on Bindings.

  • Now, go to the Site Bindings dialog box and open the binding for https on IP address * & port number 443.

  • In this step, check the valid SSL certificate specified for the Exchange site. If it is not verified, then give a valid SSL certificate like Microsoft Exchange certificate. After that, restart the IIS service by running the IISRESET /NOFORCE command.

  • Finally, perform the same verification for the Exchange back-end site on the mailbox Exchange Server and check whether this Webmail blank page after login still arises or not.

Wrapping Up

In this write-up, we have shed a light on the issue related to ECP / OWA blank page screen after Login in Exchange 2016 / 2013/ 2010. There are many causes behind this problem such as certificate binding or wrong binding information (Port Number) and. To fix this issue user Powershell command to install the right certificate and use IIS Manager to change the binding properties of SSL Certificates.